aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 3269459397..958e818da1 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -129,7 +129,11 @@ define KernelPackage/dma-buf
TITLE:=DMA shared buffer support
HIDDEN:=1
KCONFIG:=CONFIG_DMA_SHARED_BUFFER
- FILES:=$(LINUX_DIR)/drivers/dma-buf/dma-shared-buffer.ko
+ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ FILES:=$(LINUX_DIR)/drivers/dma-buf/dma-shared-buffer.ko
+ endif
+ endif
AUTOLOAD:=$(call AutoLoad,20,dma-shared-buffer)
endef
$(eval $(call KernelPackage,dma-buf))