aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index eb26a8ba08..b33883815e 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -698,6 +698,22 @@ endef
$(eval $(call KernelPackage,serial-8250))
+define KernelPackage/serial-8250-exar
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Exar 8250 UARTs
+ KCONFIG:= CONFIG_SERIAL_8250_EXAR
+ FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250_exar.ko
+ AUTOLOAD:=$(call AutoProbe,8250 8250_base 8250_exar)
+ DEPENDS:=+kmod-serial-8250
+endef
+
+define KernelPackage/serial-8250-exar/description
+ Kernel module for Exar serial ports
+endef
+
+$(eval $(call KernelPackage,serial-8250-exar))
+
+
define KernelPackage/regmap
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic register map support