aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index ca25138571..7945e72039 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1243,3 +1243,18 @@ define KernelPackage/macsec/description
endef
$(eval $(call KernelPackage,macsec))
+
+
+define KernelPackage/netlink-diag
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Netlink diag support for ss utility
+ KCONFIG:=CONFIG_NETLINK_DIAG
+ FILES:=$(LINUX_DIR)/net/netlink/netlink_diag.ko
+ AUTOLOAD:=$(call AutoLoad,31,netlink-diag)
+endef
+
+define KernelPackage/netlink-diag/description
+ Netlink diag is a module made for use with iproute2's ss utility
+endef
+
+$(eval $(call KernelPackage,netlink-diag))