aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index f204b257d1..75a06fb651 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1179,3 +1179,14 @@ define KernelPackage/nft-queue
endef
$(eval $(call KernelPackage,nft-queue))
+
+define KernelPackage/nft-compat
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter nf_tables compat support
+ DEPENDS:=+kmod-nft-core +kmod-nf-ipt
+ FILES:=$(foreach mod,$(NFT_COMPAT-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_COMPAT-m)))
+ KCONFIG:=$(KCONFIG_NFT_COMPAT)
+endef
+
+$(eval $(call KernelPackage,nft-compat))