aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk39
1 files changed, 38 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 75a06fb651..85780306f3 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -162,6 +162,28 @@ endef
$(eval $(call KernelPackage,nf-flow))
+define KernelPackage/nf-socket
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter socket lookup support
+ KCONFIG:= $(KCOFNIG_NF_SOCKET)
+ FILES:=$(foreach mod,$(NF_SOCKET-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NF_SOCKET-m)))
+endef
+
+$(eval $(call KernelPackage,nf-socket))
+
+
+define KernelPackage/nf-tproxy
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter tproxy support
+ KCONFIG:= $(KCOFNIG_NF_TPROXY)
+ FILES:=$(foreach mod,$(NF_TPROXY-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NF_TPROXY-m)))
+endef
+
+$(eval $(call KernelPackage,nf-tproxy))
+
+
define AddDepends/ipt
SUBMENU:=$(NF_MENU)
DEPENDS+= +kmod-ipt-core $(1)
@@ -645,9 +667,24 @@ endef
$(eval $(call KernelPackage,ipt-led))
+define KernelPackage/ipt-socket
+ TITLE:=Iptables socket matching support
+ DEPENDS+=+kmod-nf-socket +kmod-nf-conntrack
+ KCONFIG:=$(KCONFIG_IPT_SOCKET)
+ FILES:=$(foreach mod,$(IPT_SOCKET-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_SOCKET-m)))
+ $(call AddDepends/ipt)
+endef
+
+define KernelPackage/ipt-socket/description
+ Kernel modules for socket matching
+endef
+
+$(eval $(call KernelPackage,ipt-socket))
+
define KernelPackage/ipt-tproxy
TITLE:=Transparent proxying support
- DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +IPV6:kmod-ip6tables
+ DEPENDS+=+kmod-nf-tproxy +kmod-nf-conntrack
KCONFIG:=$(KCONFIG_IPT_TPROXY)
FILES:=$(foreach mod,$(IPT_TPROXY-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_TPROXY-m)))