aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netdevices.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netdevices.mk')
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 518d83f9a2..248aaf06f7 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -340,6 +340,22 @@ endef
$(eval $(call KernelPackage,phy-smsc))
+define KernelPackage/phy-aquantia
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Aquantia Ethernet PHYs
+ DEPENDS:=+kmod-libphy +kmod-hwmon-core
+ KCONFIG:=CONFIG_AQUANTIA_PHY
+ FILES:=$(LINUX_DIR)/drivers/net/phy/aquantia.ko
+ AUTOLOAD:=$(call AutoLoad,18,aquantia,1)
+endef
+
+define KernelPackage/phy-aquantia/description
+ Kernel modules for Aquantia Ethernet PHYs
+endef
+
+$(eval $(call KernelPackage,phy-aquantia))
+
+
define KernelPackage/swconfig
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=switch configuration API