aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netdevices.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netdevices.mk')
-rw-r--r--package/kernel/linux/modules/netdevices.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 5f8d767679..61a19bf42f 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -223,6 +223,36 @@ endef
$(eval $(call KernelPackage,swconfig))
+define KernelPackage/switch-bcm53xx
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Broadcom bcm53xx switch support
+ DEPENDS:=+kmod-swconfig
+ KCONFIG:=CONFIG_SWCONFIG_B53
+ FILES:=$(LINUX_DIR)/drivers/net/phy/b53/b53_common.ko
+ AUTOLOAD:=$(call AutoLoad,42,b53_common)
+endef
+
+define KernelPackage/switch-bcm53xx/description
+ Broadcom bcm53xx switch support
+endef
+
+$(eval $(call KernelPackage,switch-bcm53xx))
+
+define KernelPackage/switch-bcm53xx-mdio
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Broadcom bcm53xx switch MDIO support
+ DEPENDS:=+kmod-switch-bcm53xx
+ KCONFIG:=CONFIG_SWCONFIG_B53_PHY_DRIVER
+ FILES:=$(LINUX_DIR)/drivers/net/phy/b53/b53_mdio.ko
+ AUTOLOAD:=$(call AutoLoad,42,b53_mdio)
+endef
+
+define KernelPackage/switch-bcm53xx-mdio/description
+ Broadcom bcm53xx switch MDIO support
+endef
+
+$(eval $(call KernelPackage,switch-bcm53xx-mdio))
+
define KernelPackage/switch-mvsw61xx
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Marvell 88E61xx switch support