aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netdevices.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netdevices.mk')
-rw-r--r--package/kernel/linux/modules/netdevices.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 42b7a8e4ca..a9740ef35a 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -646,8 +646,9 @@ $(eval $(call KernelPackage,pcnet32))
define KernelPackage/tg3
TITLE:=Broadcom Tigon3 Gigabit Ethernet
- KCONFIG:=CONFIG_TIGON3
- DEPENDS:=+!TARGET_brcm47xx:kmod-libphy +kmod-hwmon-core +kmod-ptp
+ KCONFIG:=CONFIG_TIGON3 \
+ CONFIG_TIGON3_HWMON=n
+ DEPENDS:=+!TARGET_brcm47xx:kmod-libphy +!LINUX_4_14:kmod-hwmon-core +kmod-ptp
SUBMENU:=$(NETWORK_DEVICES_MENU)
FILES:=$(LINUX_DIR)/drivers/net/ethernet/broadcom/tg3.ko
AUTOLOAD:=$(call AutoLoad,19,tg3,1)