aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index c3c56864b7..1dddebfed7 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -345,6 +345,43 @@ endef
$(eval $(call KernelPackage,fs-jfs))
+
+define KernelPackage/fs-ksmbd
+ SUBMENU:=$(FS_MENU)
+ TITLE:=SMB kernel server support
+ DEPENDS:= \
+ +kmod-nls-base \
+ +kmod-nls-utf8 \
+ +kmod-crypto-md4 \
+ +kmod-crypto-md5 \
+ +kmod-crypto-hmac \
+ +kmod-crypto-ecb \
+ +kmod-crypto-des \
+ +kmod-crypto-sha256 \
+ +kmod-crypto-cmac \
+ +kmod-crypto-sha512 \
+ +kmod-crypto-aead \
+ +kmod-crypto-ccm \
+ +kmod-crypto-gcm \
+ +kmod-asn1-decoder \
+ +kmod-oid-registry \
+ +kmod-fs-smbfs-common
+ KCONFIG:= \
+ CONFIG_SMB_SERVER \
+ CONFIG_SMB_SERVER_SMBDIRECT=n \
+ CONFIG_SMB_SERVER_CHECK_CAP_NET_ADMIN=n \
+ CONFIG_SMB_SERVER_KERBEROS5=n
+ FILES:=$(LINUX_DIR)/fs/ksmbd/ksmbd.ko
+ AUTOLOAD:=$(call AutoLoad,41,ksmbd)
+endef
+
+define KernelPackage/fs-ksmbd/description
+ Kernel module for SMB kernel server support
+endef
+
+$(eval $(call KernelPackage,fs-ksmbd))
+
+
define KernelPackage/fs-minix
SUBMENU:=$(FS_MENU)
TITLE:=Minix filesystem support