aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index d70eb924c3..1add16e161 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -226,6 +226,18 @@ endef
$(eval $(call KernelPackage,crypto-gcm))
+define KernelPackage/crypto-xcbc
+ TITLE:=XCBC CryptoAPI module
+ DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
+ KCONFIG:=CONFIG_CRYPTO_XCBC
+ FILES:=$(LINUX_DIR)/crypto/xcbc.ko
+ AUTOLOAD:=$(call AutoLoad,09,xcbc)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-xcbc))
+
+
define KernelPackage/crypto-gf128
TITLE:=GF(2^128) multiplication functions CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_GF128MUL