aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 445b2e353b..2b0388aa10 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -101,6 +101,18 @@ endef
$(eval $(call KernelPackage,crypto-ccm))
+define KernelPackage/crypto-chacha20poly1305
+ TITLE:=ChaCha20-Poly1305 AEAD support, RFC7539 (used by strongSwan IPsec VPN)
+ DEPENDS:=+kmod-crypto-aead +kmod-crypto-manager
+ KCONFIG:=CONFIG_CRYPTO_CHACHA20POLY1305
+ FILES:=$(LINUX_DIR)/crypto/chacha20poly1305.ko
+ AUTOLOAD:=$(call AutoLoad,09,chacha20poly1305)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-chacha20poly1305))
+
+
define KernelPackage/crypto-cmac
TITLE:=Support for Cipher-based Message Authentication Code (CMAC)
DEPENDS:=+kmod-crypto-hash