aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index efcdeafa99..fc2739811a 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -363,6 +363,17 @@ endef
$(eval $(call KernelPackage,crypto-ecb))
+define KernelPackage/crypto-cts
+ TITLE:=Cipher Text Stealing CryptoAPI module
+ DEPENDS:=+kmod-crypto-manager
+ KCONFIG:=CONFIG_CRYPTO_CTS
+ FILES:=$(LINUX_DIR)/crypto/cts.ko
+ AUTOLOAD:=$(call AutoLoad,09,cts)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-cts))
+
define KernelPackage/crypto-hmac
TITLE:=HMAC digest CryptoAPI module