aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/lantiq/ltq-vdsl-vr11-mei/patches')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/001-fix-compile.patch88
-rw-r--r--package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/010-warnings.patch20
-rw-r--r--package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/020-not-leak-cflags.patch12
-rw-r--r--package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/100-compat.patch10
-rw-r--r--package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/101_no-date-time.patch13
-rw-r--r--package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/110-reset-g_tx_link_rate-on-showtime-exit.patch12
-rw-r--r--package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/120-remove-debug-printk.patch10
7 files changed, 165 insertions, 0 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/001-fix-compile.patch b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/001-fix-compile.patch
new file mode 100644
index 0000000000..ff46b1f088
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/001-fix-compile.patch
@@ -0,0 +1,88 @@
+--- a/src/drv_mei_cpe_linux.c
++++ b/src/drv_mei_cpe_linux.c
+@@ -1534,7 +1534,7 @@ struct proc_entry {
+ char name[32];
+ proc_rd_callback_t rd;
+ proc_wr_callback_t wr;
+- struct file_operations ops;
++ struct proc_ops ops;
+ int entity;
+ };
+
+@@ -2068,16 +2068,15 @@ static int mei_proc_single_open(struct i
+ static void mei_proc_entry_create(struct proc_dir_entry *parent_node,
+ struct proc_entry *proc_entry)
+ {
+- memset(&proc_entry->ops, 0, sizeof(struct file_operations));
+- proc_entry->ops.owner = THIS_MODULE;
++ memset(&proc_entry->ops, 0, sizeof(struct proc_ops));
+
+- proc_entry->ops.open = mei_proc_single_open;
+- proc_entry->ops.release = single_release;
++ proc_entry->ops.proc_open = mei_proc_single_open;
++ proc_entry->ops.proc_release = single_release;
+
+- proc_entry->ops.read = seq_read;
+- proc_entry->ops.llseek = seq_lseek;
++ proc_entry->ops.proc_read = seq_read;
++ proc_entry->ops.proc_lseek = seq_lseek;
+ if (proc_entry->wr)
+- proc_entry->ops.write = proc_entry->wr;
++ proc_entry->ops.proc_write = proc_entry->wr;
+
+ proc_create_data(proc_entry->name,
+ (S_IFREG | S_IRUGO),
+--- a/src/drv_mei_cpe_linux.h
++++ b/src/drv_mei_cpe_linux.h
+@@ -31,6 +31,7 @@
+ #include <linux/module.h>
+
+ #include <linux/sched.h>
++#include <linux/sched/signal.h>
+ #include <linux/interrupt.h>
+ #include <linux/version.h>
+ #include <linux/crc32.h>
+@@ -122,7 +123,7 @@ typedef int (*MEI_RequestIrq_WrapLinux_t
+ /**
+ Function typedef for the Linux free_irq()
+ */
+-typedef void (*MEI_FreeIrq_WrapLinux_t)( unsigned int usedIrq,
++typedef const void *(*MEI_FreeIrq_WrapLinux_t)( unsigned int usedIrq,
+ void *usedDevId );
+
+
+--- a/src/drv_mei_cpe_linux_proc_config.c
++++ b/src/drv_mei_cpe_linux_proc_config.c
+@@ -1277,13 +1277,12 @@ static int mei_proc_single_open(struct i
+ return single_open(file, mei_seq_single_show, PDE_DATA(inode));
+ }
+
+-static struct file_operations proc_ops = {
+- .owner = THIS_MODULE,
+- .open = mei_proc_single_open,
+- .release = single_release,
+- .read = seq_read,
+- .llseek = seq_lseek,
+- .write = MEI_ProcWriteConfig
++static struct proc_ops proc_ops = {
++ .proc_open = mei_proc_single_open,
++ .proc_release = single_release,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_write = MEI_ProcWriteConfig
+ };
+
+ /**
+--- a/src/mei_cpe_appl_osmap.h
++++ b/src/mei_cpe_appl_osmap.h
+@@ -38,10 +38,6 @@ extern "C"
+ #include <errno.h>
+ #include <ctype.h>
+ #include <sys/ioctl.h>
+-
+-extern int snprintf (char *__restrict __s, size_t __maxlen,
+- __const char *__restrict __format, ...)
+- __THROW __attribute__ ((__format__ (__printf__, 3, 4)));
+ #endif
+
+ /* ==========================================================================
diff --git a/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/010-warnings.patch b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/010-warnings.patch
new file mode 100644
index 0000000000..f6ee2f7f8b
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/010-warnings.patch
@@ -0,0 +1,20 @@
+--- a/src/drv_mei_cpe_dbg_driver.c
++++ b/src/drv_mei_cpe_dbg_driver.c
+@@ -309,7 +309,7 @@ MEI_STATIC IFX_void_t MEI_DbgMsgDumpLogW
+ IFX_int32_t i;
+ unsigned short paylSize;
+ union {IFX_uint8_t d8[2]; IFX_uint16_t d16;} temp16;
+- union {IFX_uint8_t d8[4]; IFX_uint16_t d32;} temp32;
++ union {IFX_uint8_t d8[4]; IFX_uint32_t d32;} temp32;
+
+ MEI_DbgMsgDumpLogLabel(pCmvMsg, fctOpCode);
+
+@@ -368,7 +368,7 @@ MEI_STATIC IFX_void_t MEI_DbgMsgDumpTrcW
+ IFX_int32_t i;
+ unsigned short paylSize;
+ union {IFX_uint8_t d8[2]; IFX_uint16_t d16;} temp16;
+- union {IFX_uint8_t d8[4]; IFX_uint16_t d32;} temp32;
++ union {IFX_uint8_t d8[4]; IFX_uint32_t d32;} temp32;
+
+ MEI_DbgMsgDumpTraceLabel(pCmvMsg, fctOpCode);
+
diff --git a/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/020-not-leak-cflags.patch b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/020-not-leak-cflags.patch
new file mode 100644
index 0000000000..f6fb48ed6e
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/020-not-leak-cflags.patch
@@ -0,0 +1,12 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -213,8 +213,7 @@ drv_mei_cpe_common_cflags = $(AM_CFLAGS)
+ else
+
+ drv_mei_cpe_common_cflags = \
+- $(AM_CFLAGS) -D__KERNEL__ -DLINUX -D__linux__ -DMODULE -DEXPORT_SYMTAB \
+- -pipe -Wall -Wimplicit -Wunused -Wuninitialized -Wstrict-aliasing -Wno-date-time
++ -D__KERNEL__ -DLINUX -D__linux__ -DMODULE -DEXPORT_SYMTAB
+
+ endif
+
diff --git a/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/100-compat.patch b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/100-compat.patch
new file mode 100644
index 0000000000..a2e42ccb03
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/100-compat.patch
@@ -0,0 +1,10 @@
+--- a/src/drv_mei_cpe_linux.c
++++ b/src/drv_mei_cpe_linux.c
+@@ -4530,7 +4530,6 @@ module_exit (MEI_module_exit);
+ #ifdef MODULE
+ MODULE_AUTHOR("www.lantiq.com");
+ MODULE_DESCRIPTION("MEI CPE Driver - www.lantiq.com");
+-MODULE_SUPPORTED_DEVICE("MEI CPE Interface");
+ MODULE_LICENSE ("GPL");
+ #endif /* #ifdef MODULE*/
+
diff --git a/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/101_no-date-time.patch b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/101_no-date-time.patch
new file mode 100644
index 0000000000..18918b9956
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/101_no-date-time.patch
@@ -0,0 +1,13 @@
+--- a/src/drv_mei_cpe_linux.c
++++ b/src/drv_mei_cpe_linux.c
+@@ -1556,8 +1556,8 @@ static void MEI_GetVersionProc(struct se
+ }
+
+ seq_printf(s, "%s" MEI_DRV_CRLF, &MEI_WHATVERSION[4]);
+- seq_printf(s, "Compiled on %s, %s for Linux kernel %s (jiffies: %ld)" MEI_DRV_CRLF,
+- __DATE__, __TIME__, UTS_RELEASE, jiffies);
++ seq_printf(s, "Compiled for Linux kernel %s (jiffies: %ld)" MEI_DRV_CRLF,
++ UTS_RELEASE, jiffies);
+ }
+
+ /**
diff --git a/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/110-reset-g_tx_link_rate-on-showtime-exit.patch b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/110-reset-g_tx_link_rate-on-showtime-exit.patch
new file mode 100644
index 0000000000..f57b8f076f
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/110-reset-g_tx_link_rate-on-showtime-exit.patch
@@ -0,0 +1,12 @@
+--- a/src/drv_mei_cpe_api_atm_ptm_intern.c
++++ b/src/drv_mei_cpe_api_atm_ptm_intern.c
+@@ -152,6 +152,9 @@ IFX_int32_t MEI_InternalXtmSwhowtimeExit
+ /* Get line number*/
+ dslLineNum = pMeiDynCntrl->pMeiDev->meiDrvCntrl.dslLineNum;
+
++ g_tx_link_rate[dslLineNum][0] = 0;
++ g_tx_link_rate[dslLineNum][1] = 0;
++
+ #ifdef PPA_SUPPORTS_CALLBACKS
+ /* get NULL or function pointer */
+ mei_showtime_exit =
diff --git a/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/120-remove-debug-printk.patch b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/120-remove-debug-printk.patch
new file mode 100644
index 0000000000..24db470c4a
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/120-remove-debug-printk.patch
@@ -0,0 +1,10 @@
+--- a/src/drv_mei_cpe_mei_access_vrx.c
++++ b/src/drv_mei_cpe_mei_access_vrx.c
+@@ -1691,7 +1691,6 @@ IFX_int32_t MEI_InterfaceDetect(
+ {
+ MEI_REG_ACCESS_ME_VERSION_SET(pMeiDrvCntrl, 0x00000000);
+ hwVers = MEI_REG_ACCESS_ME_VERSION_GET(pMeiDrvCntrl);
+- printk ("hwVers=0x%08X\n", hwVers);
+
+ if (MEI_DEVICE_CFG_IS_PLATFORM(e_MEI_DEV_PLATFORM_CONFIG_VR9))
+ {