aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-ifxos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/lantiq/ltq-ifxos/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-ifxos/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/kernel/lantiq/ltq-ifxos/Makefile b/package/kernel/lantiq/ltq-ifxos/Makefile
index bc586faaf1..e8f41665dd 100644
--- a/package/kernel/lantiq/ltq-ifxos/Makefile
+++ b/package/kernel/lantiq/ltq-ifxos/Makefile
@@ -32,7 +32,7 @@ define KernelPackage/ltq-ifxos
SUBMENU:=Libraries
TITLE:=Lantiq OS abstraction library
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq
+ DEPENDS:=@(TARGET_lantiq||TARGET_ipq40xx)
FILES:=$(PKG_BUILD_DIR)/src/drv_ifxos.ko
AUTOLOAD:=$(call AutoLoad,10,drv_ifxos)
endef
@@ -44,13 +44,11 @@ CONFIGURE_ARGS += \
--enable-kernelincl="$(LINUX_DIR)/include" \
--with-kernel-module
-ifdef CONFIG_TARGET_lantiq
- define Build/InstallDev
+define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/{lib,include/ifxos}
$(CP) $(PKG_BUILD_DIR)/src/include/* $(1)/usr/include/ifxos
mkdir -p $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/src/.libs/libifxos.a $(1)/usr/lib/libifxos.a
- endef
-endif
+endef
$(eval $(call KernelPackage,ltq-ifxos))