aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/Makefile')
-rw-r--r--package/kernel/Makefile52
1 files changed, 0 insertions, 52 deletions
diff --git a/package/kernel/Makefile b/package/kernel/Makefile
deleted file mode 100644
index d44b5a7767..0000000000
--- a/package/kernel/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=kernel
-PKG_FLAGS:=hold
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
-SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk
-
-PKG_LICENSE:=GPLv2
-PKG_LICENSE_FILES:=
-
-include $(INCLUDE_DIR)/package.mk
-ifeq ($(DUMP),)
- -include $(LINUX_DIR)/.config
-endif
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-CONFIG_PACKAGE_kernel=y
-define Package/kernel
- SECTION:=sys
- CATEGORY:=Kernel
- DEFAULT:=y
- TITLE:=Virtual kernel package
- VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC)
- URL:=http://www.kernel.org/
-endef
-
-define Package/kernel/install
- # nothing to do
-endef
-
-$(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
-
-include $(sort $(wildcard ./modules/*.mk))
--include $(TOPDIR)/target/linux/*/modules.mk