aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index 640b5658fd..80681f5577 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -63,6 +63,12 @@ define Build/Configure
> $(PKG_BUILD_DIR)/include/SNAPSHOT.h
endef
+ifdef CONFIG_USE_EGLIBC
+ ifndef CONFIG_EGLIBC_VERSION_2_13
+ TARGET_CFLAGS += -DHAVE_SETNS
+ endif
+endif
+
MAKE_FLAGS += \
EXTRA_CCOPTS="$(TARGET_CFLAGS) -I../include -I$(STAGING_DIR)/usr/include/libnl-tiny" \
KERNEL_INCLUDE="$(LINUX_DIR)/include" \