aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/hostapd/patches')
-rw-r--r--package/hostapd/patches/001-cross_compile_fix.patch35
-rw-r--r--package/hostapd/patches/100-madwifi_fixes.patch52
2 files changed, 87 insertions, 0 deletions
diff --git a/package/hostapd/patches/001-cross_compile_fix.patch b/package/hostapd/patches/001-cross_compile_fix.patch
new file mode 100644
index 0000000000..8b5ca681d2
--- /dev/null
+++ b/package/hostapd/patches/001-cross_compile_fix.patch
@@ -0,0 +1,35 @@
+Common subdirectories: hostapd-0.5.2/logwatch and hostapd-0.5.2.new/logwatch
+diff -u hostapd-0.5.2/Makefile hostapd-0.5.2.new/Makefile
+--- hostapd-0.5.2/Makefile 2006-03-20 03:20:09.000000000 +0000
++++ hostapd-0.5.2.new/Makefile 2006-03-21 22:25:23.803473592 +0000
+@@ -3,7 +3,7 @@
+ DIR_HOSTAP=.
+
+ ifndef CFLAGS
+-CFLAGS = -MMD -O2 -Wall -g
++CFLAGS = -MMD $(OPTFLAGS) $(CPPFLAGS)
+ endif
+
+ # define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
+@@ -266,7 +266,7 @@
+ for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
+
+ hostapd: $(OBJS)
+- $(CC) -o hostapd $(OBJS) $(LIBS)
++ $(CC) -o hostapd $(OBJS) $(LDFLAGS) $(LIBS)
+
+ driver_conf.c: Makefile .config
+ rm -f driver_conf.c
+@@ -330,10 +330,10 @@
+ endif
+
+ nt_password_hash: $(NOBJS)
+- $(CC) -o nt_password_hash $(NOBJS) $(LIBS_n)
++ $(CC) -o nt_password_hash $(NOBJS) $(LDFLAGS) $(LIBS_n)
+
+ hlr_auc_gw: $(HOBJS)
+- $(CC) -o hlr_auc_gw $(HOBJS) $(LIBS_h)
++ $(CC) -o hlr_auc_gw $(HOBJS) $(LDFLAGS) $(LIBS_h)
+
+ clean:
+ rm -f core *~ *.o hostapd hostapd_cli nt_password_hash hlr_auc_gw
diff --git a/package/hostapd/patches/100-madwifi_fixes.patch b/package/hostapd/patches/100-madwifi_fixes.patch
new file mode 100644
index 0000000000..eb7299b41a
--- /dev/null
+++ b/package/hostapd/patches/100-madwifi_fixes.patch
@@ -0,0 +1,52 @@
+diff -ur hostapd.old/driver_madwifi.c hostapd.dev/driver_madwifi.c
+--- hostapd.old/driver_madwifi.c 2006-03-25 20:55:18.000000000 +0100
++++ hostapd.dev/driver_madwifi.c 2006-06-12 21:54:22.000000000 +0200
+@@ -20,11 +20,6 @@
+
+ #include <include/compat.h>
+ #include <net80211/ieee80211.h>
+-#ifdef WME_NUM_AC
+-/* Assume this is built against BSD branch of madwifi driver. */
+-#define MADWIFI_BSD
+-#include <net80211/_ieee80211.h>
+-#endif /* WME_NUM_AC */
+ #include <net80211/ieee80211_crypto.h>
+ #include <net80211/ieee80211_ioctl.h>
+
+@@ -168,7 +164,10 @@
+ }
+ return 0;
+ }
+-
++static int madwifi_get_inact_sec(void *priv, const u8 *addr)
++{
++return 0;
++}
+ static int
+ set80211param(struct madwifi_driver_data *drv, int op, int arg)
+ {
+@@ -1204,8 +1203,6 @@
+ goto bad;
+ }
+
+- madwifi_set_iface_flags(drv, 0); /* mark down during setup */
+-
+ hapd->driver = &drv->ops;
+ return 0;
+ bad:
+@@ -1226,7 +1223,6 @@
+
+ drv->hapd->driver = NULL;
+
+- (void) madwifi_set_iface_flags(drv, 0);
+ if (drv->ioctl_sock >= 0)
+ close(drv->ioctl_sock);
+ if (drv->sock_recv != NULL && drv->sock_recv != drv->sock_xmit)
+@@ -1306,6 +1452,7 @@
+ .get_ssid = madwifi_get_ssid,
+ .set_countermeasures = madwifi_set_countermeasures,
+ .sta_clear_stats = madwifi_sta_clear_stats,
++ .get_inact_sec = madwifi_get_inact_sec,
+ };
+
+ void madwifi_driver_register(void)