aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/patches/560-disable_ctrl_iface_mib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/hostapd/patches/560-disable_ctrl_iface_mib.patch')
-rw-r--r--package/hostapd/patches/560-disable_ctrl_iface_mib.patch30
1 files changed, 15 insertions, 15 deletions
diff --git a/package/hostapd/patches/560-disable_ctrl_iface_mib.patch b/package/hostapd/patches/560-disable_ctrl_iface_mib.patch
index 77352f1324..22f282ab5b 100644
--- a/package/hostapd/patches/560-disable_ctrl_iface_mib.patch
+++ b/package/hostapd/patches/560-disable_ctrl_iface_mib.patch
@@ -1,6 +1,6 @@
--- a/hostapd/Makefile
+++ b/hostapd/Makefile
-@@ -119,6 +119,9 @@ endif
+@@ -128,6 +128,9 @@ endif
ifdef CONFIG_NO_CTRL_IFACE
CFLAGS += -DCONFIG_NO_CTRL_IFACE
else
@@ -12,7 +12,7 @@
endif
--- a/hostapd/ctrl_iface.c
+++ b/hostapd/ctrl_iface.c
-@@ -855,6 +855,7 @@ static void hostapd_ctrl_iface_receive(i
+@@ -906,6 +906,7 @@ static void hostapd_ctrl_iface_receive(i
} else if (os_strncmp(buf, "RELOG", 5) == 0) {
if (wpa_debug_reopen_file() < 0)
reply_len = -1;
@@ -20,7 +20,7 @@
} else if (os_strcmp(buf, "MIB") == 0) {
reply_len = ieee802_11_get_mib(hapd, reply, reply_size);
if (reply_len >= 0) {
-@@ -884,10 +885,12 @@ static void hostapd_ctrl_iface_receive(i
+@@ -935,10 +936,12 @@ static void hostapd_ctrl_iface_receive(i
reply_len += res;
}
#endif /* CONFIG_NO_RADIUS */
@@ -33,7 +33,7 @@
} else if (os_strcmp(buf, "STA-FIRST") == 0) {
reply_len = hostapd_ctrl_iface_sta_first(hapd, reply,
reply_size);
-@@ -897,6 +900,7 @@ static void hostapd_ctrl_iface_receive(i
+@@ -948,6 +951,7 @@ static void hostapd_ctrl_iface_receive(i
} else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
reply_len = hostapd_ctrl_iface_sta_next(hapd, buf + 9, reply,
reply_size);
@@ -43,7 +43,7 @@
reply_len = -1;
--- a/wpa_supplicant/Makefile
+++ b/wpa_supplicant/Makefile
-@@ -675,6 +675,9 @@ ifdef CONFIG_IEEE80211N
+@@ -709,6 +709,9 @@ ifdef CONFIG_IEEE80211N
OBJS += ../src/ap/ieee802_11_ht.o
endif
ifdef CONFIG_CTRL_IFACE
@@ -55,7 +55,7 @@
--- a/wpa_supplicant/ctrl_iface.c
+++ b/wpa_supplicant/ctrl_iface.c
-@@ -2929,6 +2929,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -3231,6 +3231,7 @@ char * wpa_supplicant_ctrl_iface_process
reply_len = -1;
} else if (os_strncmp(buf, "NOTE ", 5) == 0) {
wpa_printf(MSG_INFO, "NOTE: %s", buf + 5);
@@ -63,7 +63,7 @@
} else if (os_strcmp(buf, "MIB") == 0) {
reply_len = wpa_sm_get_mib(wpa_s->wpa, reply, reply_size);
if (reply_len >= 0) {
-@@ -2940,6 +2941,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -3242,6 +3243,7 @@ char * wpa_supplicant_ctrl_iface_process
else
reply_len += res;
}
@@ -71,7 +71,7 @@
} else if (os_strncmp(buf, "STATUS", 6) == 0) {
reply_len = wpa_supplicant_ctrl_iface_status(
wpa_s, buf + 6, reply, reply_size);
-@@ -3245,6 +3247,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -3570,6 +3572,7 @@ char * wpa_supplicant_ctrl_iface_process
reply_len = wpa_supplicant_ctrl_iface_bss(
wpa_s, buf + 4, reply, reply_size);
#ifdef CONFIG_AP
@@ -79,7 +79,7 @@
} else if (os_strcmp(buf, "STA-FIRST") == 0) {
reply_len = ap_ctrl_iface_sta_first(wpa_s, reply, reply_size);
} else if (os_strncmp(buf, "STA ", 4) == 0) {
-@@ -3253,6 +3256,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -3578,6 +3581,7 @@ char * wpa_supplicant_ctrl_iface_process
} else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
reply_len = ap_ctrl_iface_sta_next(wpa_s, buf + 9, reply,
reply_size);
@@ -105,7 +105,7 @@
+#endif
--- a/src/ap/ieee802_1x.c
+++ b/src/ap/ieee802_1x.c
-@@ -1896,6 +1896,7 @@ static const char * bool_txt(Boolean boo
+@@ -1926,6 +1926,7 @@ static const char * bool_txt(Boolean boo
return bool ? "TRUE" : "FALSE";
}
@@ -113,7 +113,7 @@
int ieee802_1x_get_mib(struct hostapd_data *hapd, char *buf, size_t buflen)
{
-@@ -2047,6 +2048,7 @@ int ieee802_1x_get_mib_sta(struct hostap
+@@ -2078,6 +2079,7 @@ int ieee802_1x_get_mib_sta(struct hostap
return len;
}
@@ -123,7 +123,7 @@
struct sta_info *sta, int success)
--- a/src/ap/wpa_auth.c
+++ b/src/ap/wpa_auth.c
-@@ -2491,6 +2491,7 @@ static int wpa_cipher_bits(int cipher)
+@@ -2534,6 +2534,7 @@ static int wpa_cipher_bits(int cipher)
}
}
@@ -131,7 +131,7 @@
#define RSN_SUITE "%02x-%02x-%02x-%d"
#define RSN_SUITE_ARG(s) \
-@@ -2654,7 +2655,7 @@ int wpa_get_mib_sta(struct wpa_state_mac
+@@ -2697,7 +2698,7 @@ int wpa_get_mib_sta(struct wpa_state_mac
return len;
}
@@ -142,7 +142,7 @@
{
--- a/src/rsn_supp/wpa.c
+++ b/src/rsn_supp/wpa.c
-@@ -1913,6 +1913,8 @@ static u32 wpa_cipher_suite(struct wpa_s
+@@ -1919,6 +1919,8 @@ static u32 wpa_cipher_suite(struct wpa_s
}
@@ -151,7 +151,7 @@
#define RSN_SUITE "%02x-%02x-%02x-%d"
#define RSN_SUITE_ARG(s) \
((s) >> 24) & 0xff, ((s) >> 16) & 0xff, ((s) >> 8) & 0xff, (s) & 0xff
-@@ -1992,6 +1994,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
+@@ -1998,6 +2000,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
return (int) len;
}