aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/patches/510-multicall.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/hostapd/patches/510-multicall.patch')
-rw-r--r--package/hostapd/patches/510-multicall.patch48
1 files changed, 24 insertions, 24 deletions
diff --git a/package/hostapd/patches/510-multicall.patch b/package/hostapd/patches/510-multicall.patch
index 98d89f1095..99fb76c43e 100644
--- a/package/hostapd/patches/510-multicall.patch
+++ b/package/hostapd/patches/510-multicall.patch
@@ -8,7 +8,7 @@
ifndef CONFIG_OS
ifdef CONFIG_NATIVE_WINDOWS
-@@ -159,10 +160,14 @@ ifdef CONFIG_IEEE80211N
+@@ -168,10 +169,14 @@ ifdef CONFIG_IEEE80211N
CFLAGS += -DCONFIG_IEEE80211N
endif
@@ -26,7 +26,7 @@
LIBS += $(DRV_AP_LIBS)
ifdef CONFIG_L2_PACKET
-@@ -780,6 +785,12 @@ install: all
+@@ -799,6 +804,12 @@ install: all
BCHECK=../src/drivers/build.hostapd
@@ -39,7 +39,7 @@
hostapd: $(BCHECK) $(OBJS)
$(Q)$(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
@$(E) " LD " $@
-@@ -820,6 +831,12 @@ HOBJS += ../src/crypto/aes-internal.o
+@@ -837,6 +848,12 @@ HOBJS += ../src/crypto/aes-internal.o
HOBJS += ../src/crypto/aes-internal-enc.o
endif
@@ -54,15 +54,15 @@
@$(E) " LD " $@
--- a/wpa_supplicant/Makefile
+++ b/wpa_supplicant/Makefile
-@@ -53,6 +53,7 @@ OBJS_c = wpa_cli.o ../src/common/wpa_ctr
- OBJS_c += ../src/utils/wpa_debug.o
+@@ -14,6 +14,7 @@ CFLAGS += -I../src
+ CFLAGS += -I../src/utils
-include .config
+-include $(if $(MULTICALL),../hostapd/.config)
- ifndef CONFIG_OS
- ifdef CONFIG_NATIVE_WINDOWS
-@@ -634,6 +635,10 @@ ifdef CONFIG_DYNAMIC_EAP_METHODS
+ ALL=wpa_supplicant wpa_cli
+
+@@ -663,6 +664,10 @@ ifdef CONFIG_DYNAMIC_EAP_METHODS
CFLAGS += -DCONFIG_DYNAMIC_EAP_METHODS
LIBS += -ldl -rdynamic
endif
@@ -73,7 +73,7 @@
endif
ifdef CONFIG_AP
-@@ -642,9 +647,11 @@ NEED_EAP_COMMON=y
+@@ -671,9 +676,11 @@ NEED_EAP_COMMON=y
NEED_RSN_AUTHENTICATOR=y
CFLAGS += -DCONFIG_AP
OBJS += ap.o
@@ -85,7 +85,7 @@
OBJS += ../src/ap/hostapd.o
OBJS += ../src/ap/wpa_auth_glue.o
OBJS += ../src/ap/utils.o
-@@ -688,10 +695,18 @@ CFLAGS += -DEAP_SERVER_WSC
+@@ -718,10 +725,18 @@ CFLAGS += -DEAP_SERVER_WSC
OBJS += ../src/ap/wps_hostapd.o
OBJS += ../src/eap_server/eap_server_wsc.o
endif
@@ -104,7 +104,7 @@
NEED_AES_WRAP=y
OBJS += ../src/ap/wpa_auth.o
OBJS += ../src/ap/wpa_auth_ie.o
-@@ -1352,6 +1367,12 @@ wpa_priv: $(BCHECK) $(OBJS_priv)
+@@ -1397,6 +1412,12 @@ wpa_priv: $(BCHECK) $(OBJS_priv)
$(Q)$(LDO) $(LDFLAGS) -o wpa_priv $(OBJS_priv) $(LIBS)
@$(E) " LD " $@
@@ -117,9 +117,9 @@
wpa_supplicant: .config $(BCHECK) $(OBJS) $(EXTRA_progs)
$(Q)$(LDO) $(LDFLAGS) -o wpa_supplicant $(OBJS) $(LIBS) $(EXTRALIBS)
@$(E) " LD " $@
-@@ -1412,6 +1433,12 @@ eap_ikev2.so: ../src/eap_peer/eap_ikev2.
- $(Q)$(CC) -c -o $@ $(CFLAGS) $<
- @$(E) " CC " $<
+@@ -1460,6 +1481,12 @@ eap_ikev2.so: ../src/eap_peer/eap_ikev2.
+ %.service: %.service.in
+ sed -e 's|\@BINDIR\@|$(BINDIR)|g' $< >$@
+dump_cflags:
+ @echo -n $(CFLAGS) " "
@@ -132,7 +132,7 @@
wpa_cli.exe: wpa_cli
--- a/src/drivers/driver.h
+++ b/src/drivers/driver.h
-@@ -3199,8 +3199,8 @@ union wpa_event_data {
+@@ -3452,8 +3452,8 @@ union wpa_event_data {
* Driver wrapper code should call this function whenever an event is received
* from the driver.
*/
@@ -145,7 +145,7 @@
/*
--- a/src/ap/drv_callbacks.c
+++ b/src/ap/drv_callbacks.c
-@@ -448,8 +448,8 @@ static void hostapd_event_eapol_rx(struc
+@@ -467,8 +467,8 @@ static void hostapd_event_eapol_rx(struc
}
@@ -162,9 +162,9 @@
}
--void wpa_supplicant_event(void *ctx, wpa_event_type event,
+-void wpa_supplicant_event(void *ctx, enum wpa_event_type event,
- union wpa_event_data *data)
-+static void supplicant_event(void *ctx, wpa_event_type event,
++static void supplicant_event(void *ctx, enum wpa_event_type event,
+ union wpa_event_data *data)
{
struct wpa_priv_interface *iface = ctx;
@@ -179,7 +179,7 @@
for (;;) {
--- a/wpa_supplicant/events.c
+++ b/wpa_supplicant/events.c
-@@ -1746,8 +1746,8 @@ static void wpa_supplicant_event_unprot_
+@@ -1936,8 +1936,8 @@ static void wnm_action_rx(struct wpa_sup
}
@@ -192,7 +192,7 @@
u16 reason_code = 0;
--- a/wpa_supplicant/wpa_supplicant.c
+++ b/wpa_supplicant/wpa_supplicant.c
-@@ -2314,6 +2314,9 @@ static void wpa_supplicant_deinit_iface(
+@@ -2412,6 +2412,9 @@ static void wpa_supplicant_deinit_iface(
wpa_drv_deinit(wpa_s);
}
@@ -202,7 +202,7 @@
/**
* wpa_supplicant_add_iface - Add a new network interface
-@@ -2497,6 +2500,7 @@ struct wpa_global * wpa_supplicant_init(
+@@ -2602,6 +2605,7 @@ struct wpa_global * wpa_supplicant_init(
wpa_msg_register_ifname_cb(wpa_supplicant_msg_ifname_cb);
#endif /* CONFIG_NO_WPA_MSG */
@@ -212,7 +212,7 @@
wpa_debug_open_syslog();
--- a/hostapd/main.c
+++ b/hostapd/main.c
-@@ -502,6 +502,9 @@ static const char * hostapd_msg_ifname_c
+@@ -556,6 +556,9 @@ static const char * hostapd_msg_ifname_c
return NULL;
}
@@ -222,13 +222,13 @@
int main(int argc, char *argv[])
{
-@@ -514,6 +517,7 @@ int main(int argc, char *argv[])
+@@ -569,6 +572,7 @@ int main(int argc, char *argv[])
if (os_program_init())
return -1;
+ wpa_supplicant_event = hostapd_wpa_event;
for (;;) {
- c = getopt(argc, argv, "Bdf:hKP:tv");
+ c = getopt(argc, argv, "Bde:f:hKP:tv");
if (c < 0)
--- a/src/drivers/drivers.c
+++ b/src/drivers/drivers.c