aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 774d08e13f..782cf73f1b 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -53,6 +53,8 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSI
include $(INCLUDE_DIR)/package.mk
+STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(CONFIG_WPA_MSG_MIN_PRIORITY)
+
ifneq ($(CONFIG_DRIVER_11N_SUPPORT),)
HOSTAPD_IEEE80211N:=y
endif
@@ -218,7 +220,8 @@ TARGET_CPPFLAGS := \
$(TARGET_CPPFLAGS) \
-I$(STAGING_DIR)/usr/include/madwifi \
-DCONFIG_LIBNL20 \
- -D_GNU_SOURCE
+ -D_GNU_SOURCE \
+ $(if $(CONFIG_WPA_MSG_MIN_PRIORITY),-DCONFIG_MSG_MIN_PRIORITY=$(CONFIG_WPA_MSG_MIN_PRIORITY))
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections