aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub
diff options
context:
space:
mode:
Diffstat (limited to 'package/grub')
-rw-r--r--package/grub/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 9a50f820ec..20232f4954 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -36,9 +36,12 @@ CONFIGURE_FLAGS:=
ifneq ($(HOST_OS),Darwin)
define Build/Configure
(cd $(PKG_BUILD_DIR); \
+ CFLAGS="-march=i486 -m32" \
LDFLAGS="-static" \
./configure \
$(CONFIGURE_FLAGS) \
+ --build=i386-linux-gnu \
+ --host=i386-linux-gnu \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \