aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub
diff options
context:
space:
mode:
Diffstat (limited to 'package/grub')
-rw-r--r--package/grub/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 7dfd1429d2..434af2bc9b 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -45,6 +45,7 @@ else
CONFIGURE_FLAGS:=
endif
+ifneq ($(HOST_OS),Darwin)
define Build/Configure
(cd $(PKG_BUILD_DIR); \
LDFLAGS="-static" \
@@ -83,5 +84,6 @@ define Build/InstallDev
install
mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
endef
+endif
$(eval $(call BuildPackage,grub))