aboutsummaryrefslogtreecommitdiffstats
path: root/package/fakeidentd
diff options
context:
space:
mode:
Diffstat (limited to 'package/fakeidentd')
-rw-r--r--package/fakeidentd/Config.in8
-rw-r--r--package/fakeidentd/Makefile37
-rw-r--r--package/fakeidentd/files/fakeidentd.init18
-rw-r--r--package/fakeidentd/ipkg/fakeidentd.control4
4 files changed, 67 insertions, 0 deletions
diff --git a/package/fakeidentd/Config.in b/package/fakeidentd/Config.in
new file mode 100644
index 0000000000..ddfa3a9992
--- /dev/null
+++ b/package/fakeidentd/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_FAKEIDENTD
+ prompt "fakeidentd........................ A static, secure identd."
+ tristate
+ default m if CONFIG_DEVEL
+ help
+ A static secure identd, only one source file.
+
+ http://www.guru-group.fi/~too/sw/releases/
diff --git a/package/fakeidentd/Makefile b/package/fakeidentd/Makefile
new file mode 100644
index 0000000000..fa61f35366
--- /dev/null
+++ b/package/fakeidentd/Makefile
@@ -0,0 +1,37 @@
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fakeidentd
+PKG_VERSION:=2.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=aa4133981c94c59868344cd3b02e8e19
+
+PKG_SOURCE_URL:=http://distfiles.gentoo.org/distfiles/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,FAKEIDENTD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(TARGET_CC) -o $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/identd.c
+ touch $@
+
+$(IPKG_FAKEIDENTD):
+ install -d -m0755 $(IDIR_FAKEIDENTD)/usr/sbin \
+ $(IDIR_FAKEIDENTD)/etc/init.d \
+ $(IDIR_FAKEIDENTD)/etc/default/
+ echo $(whoami) > $(IDIR_FAKEIDENTD)/etc/default/$(PKG_NAME)
+ $(CP) $(PKG_BUILD_DIR)/fakeidentd $(IDIR_FAKEIDENTD)/usr/sbin/
+ $(CP) ./files/$(PKG_NAME).init $(IDIR_FAKEIDENTD)/etc/init.d/$(PKG_NAME)
+ $(RSTRIP) $(IDIR_FAKEIDENTD)
+ $(IPKG_BUILD) $(IDIR_FAKEIDENTD) $(PACKAGE_DIR)
+
diff --git a/package/fakeidentd/files/fakeidentd.init b/package/fakeidentd/files/fakeidentd.init
new file mode 100644
index 0000000000..954ad8c24c
--- /dev/null
+++ b/package/fakeidentd/files/fakeidentd.init
@@ -0,0 +1,18 @@
+#!/bin/sh
+NAME=fakeidentd
+case "$1" in
+ start)
+ [ -e $DEFAULT ] && $NAME $DEFAULT
+ ;;
+ stop)
+ killall $NAME
+ ;;
+ restart)
+ killall $NAME
+ $NAME
+ ;;
+ *)
+ echo "Usage: $NAME (start|stop|restart)" > 2&
+ exit 1
+ ;;
+esac
diff --git a/package/fakeidentd/ipkg/fakeidentd.control b/package/fakeidentd/ipkg/fakeidentd.control
new file mode 100644
index 0000000000..6c528b2752
--- /dev/null
+++ b/package/fakeidentd/ipkg/fakeidentd.control
@@ -0,0 +1,4 @@
+Package: fakeidentd
+Description: A static, secure identd.
+Section: net
+Priority: optional