aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 493797fa28..b71db58587 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -33,12 +33,15 @@ define Package/dnsmasq/conffiles
/etc/dnsmasq.conf
endef
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
BINDIR="/usr/sbin" MANDIR="/usr/man" \
AWK="awk" \
+ LDFLAGS="-Wl,--gc-sections" \
all
endef