aboutsummaryrefslogtreecommitdiffstats
path: root/package/crda/patches/101-make_crypto_use_optional.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/crda/patches/101-make_crypto_use_optional.patch')
-rw-r--r--package/crda/patches/101-make_crypto_use_optional.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/crda/patches/101-make_crypto_use_optional.patch b/package/crda/patches/101-make_crypto_use_optional.patch
new file mode 100644
index 0000000000..105ffb36e7
--- /dev/null
+++ b/package/crda/patches/101-make_crypto_use_optional.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -29,7 +29,9 @@ LDLIBS += `pkg-config --libs openssl`
+
+ reglib.o: keys-ssl.c
+
+-else
++endif
++
++ifeq ($(USE_GCRYPT),1)
+ CFLAGS += -DUSE_GCRYPT
+ LDLIBS += -lgcrypt
+