aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/grub2/Makefile2
-rw-r--r--package/boot/rbcfg/Makefile2
-rw-r--r--package/boot/yamonenv/Makefile2
3 files changed, 6 insertions, 0 deletions
diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index 2742118671..ca94b1878a 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -25,6 +25,8 @@ PKG_BUILD_DEPENDS:=grub2/host
PKG_SSP:=0
+PKG_FLAGS:=nonshared
+
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/rbcfg/Makefile b/package/boot/rbcfg/Makefile
index 7ba3d932b0..412f7ab11a 100644
--- a/package/boot/rbcfg/Makefile
+++ b/package/boot/rbcfg/Makefile
@@ -12,6 +12,8 @@ PKG_RELEASE:=1
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+PKG_FLAGS:=nonshared
+
include $(INCLUDE_DIR)/package.mk
define Package/rbcfg
diff --git a/package/boot/yamonenv/Makefile b/package/boot/yamonenv/Makefile
index 63293d4739..011d39acd6 100644
--- a/package/boot/yamonenv/Makefile
+++ b/package/boot/yamonenv/Makefile
@@ -17,6 +17,8 @@ PKG_HASH:=466eca9cdad2c15e957fb9ce7d0b6927ecd17d85c4cc2dff37e97a3e6b209c67
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_FLAGS:=nonshared
+
include $(INCLUDE_DIR)/package.mk
define Package/yamonenv