aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/at91bootstrap/Makefile14
-rw-r--r--package/boot/uboot-at91/Makefile7
2 files changed, 21 insertions, 0 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index f66472fa9c..56e14c5770 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -40,6 +40,18 @@ define AT91Bootstrap/at91sam9x5eksd_uboot
BUILD_DEVICES:=atmel_at91sam9x25ek atmel_at91sam9x35ek
endef
+define AT91Bootstrap/sama5d2_icpdf_qspi_uboot
+ TITLE:=AT91Bootstrap for SAMA5D2 ICP board (QSPI Flash)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d2-icp
+endef
+
+define AT91Bootstrap/sama5d2_icpsd_uboot
+ TITLE:=AT91Bootstrap for SAMA5D2 ICP board (SDcard)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d2-icp
+endef
+
define AT91Bootstrap/sama5d2_xplaineddf_uboot
TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
@@ -121,6 +133,8 @@ endef
AT91BOOTSTRAP_TARGETS := \
at91sam9x5eknf_uboot \
at91sam9x5eksd_uboot \
+ sama5d2_icpdf_qspi_uboot \
+ sama5d2_icpsd_uboot \
sama5d2_xplaineddf_uboot \
sama5d2_xplaineddf_qspi_uboot \
sama5d2_xplainedsd_uboot \
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 06cfcd9045..822d71f796 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -59,6 +59,12 @@ define U-Boot/sama5d3_xplained_mmc
BUILD_DEVICES:=microchip_sama5d3-xplained
endef
+define U-Boot/sama5d2_icp_mmc
+ NAME:=SAMA5D2 ICP board (SDCard)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d2-icp
+endef
+
define U-Boot/sama5d2_xplained_spiflash
NAME:=SAMA5D2 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
@@ -119,6 +125,7 @@ UBOOT_TARGETS := \
at91sam9x5ek_mmc \
sama5d3_xplained_nandflash \
sama5d3_xplained_mmc \
+ sama5d2_icp_mmc \
sama5d2_xplained_mmc \
sama5d2_xplained_spiflash \
sama5d4_xplained_mmc \