aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-omap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-omap/Makefile')
-rw-r--r--package/boot/uboot-omap/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index b519d6fb80..70c8af1dc4 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -19,7 +19,6 @@ include $(INCLUDE_DIR)/package.mk
define U-Boot/Default
BUILD_TARGET:=omap
UBOOT_IMAGE:=u-boot.img MLO
- UENV:=default
endef
define U-Boot/omap4_panda
@@ -51,7 +50,8 @@ define Build/InstallDev
$(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(device)/
)
$(foreach device,$(BUILD_DEVICES), \
- $(CP) ./files/uEnv-$(UENV).txt $(STAGING_DIR_IMAGE)/$(device)/uEnv.txt
+ mkimage -C none -A arm -T script -d ./files/boot.scr.txt \
+ $(STAGING_DIR_IMAGE)/$(device)/boot.scr
)
endef