aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/patches/133-arm64-dts-a3720-add-support-for-boards-with-populate.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-mvebu/patches/133-arm64-dts-a3720-add-support-for-boards-with-populate.patch')
-rw-r--r--package/boot/uboot-mvebu/patches/133-arm64-dts-a3720-add-support-for-boards-with-populate.patch89
1 files changed, 89 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/patches/133-arm64-dts-a3720-add-support-for-boards-with-populate.patch b/package/boot/uboot-mvebu/patches/133-arm64-dts-a3720-add-support-for-boards-with-populate.patch
new file mode 100644
index 0000000000..f35b45d0e1
--- /dev/null
+++ b/package/boot/uboot-mvebu/patches/133-arm64-dts-a3720-add-support-for-boards-with-populate.patch
@@ -0,0 +1,89 @@
+From 83908b6e2e5a7d7b0f4d040ffb4bf3ce6807b8fe Mon Sep 17 00:00:00 2001
+From: Andre Heider <a.heider@gmail.com>
+Date: Fri, 4 Sep 2020 15:44:41 +0200
+Subject: [PATCH] arm64: dts: a3720: add support for boards with populated emmc
+
+Import armada-3720-espressobin-emmc.dts from Linux, but use sdhc1 for
+emmc, since sdhc0 is used for the sd card.
+
+Signed-off-by: Andre Heider <a.heider@gmail.com>
+---
+ arch/arm/dts/Makefile | 1 +
+ arch/arm/dts/armada-3720-espressobin-emmc.dts | 44 +++++++++++++++++++
+ doc/README.marvell | 7 ++-
+ 3 files changed, 50 insertions(+), 2 deletions(-)
+ create mode 100644 arch/arm/dts/armada-3720-espressobin-emmc.dts
+
+--- a/arch/arm/dts/Makefile
++++ b/arch/arm/dts/Makefile
+@@ -202,6 +202,7 @@ dtb-$(CONFIG_ARCH_TEGRA) += tegra20-harm
+ dtb-$(CONFIG_ARCH_MVEBU) += \
+ armada-3720-db.dtb \
+ armada-3720-espressobin.dtb \
++ armada-3720-espressobin-emmc.dtb \
+ armada-3720-turris-mox.dtb \
+ armada-3720-uDPU.dtb \
+ armada-375-db.dtb \
+--- /dev/null
++++ b/arch/arm/dts/armada-3720-espressobin-emmc.dts
+@@ -0,0 +1,44 @@
++// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
++/*
++ * Device Tree file for Globalscale Marvell ESPRESSOBin Board with eMMC
++ * Copyright (C) 2018 Marvell
++ *
++ * Romain Perier <romain.perier@free-electrons.com>
++ * Konstantin Porotchkin <kostap@marvell.com>
++ *
++ */
++/*
++ * Schematic available at http://espressobin.net/wp-content/uploads/2017/08/ESPRESSObin_V5_Schematics.pdf
++ */
++
++/dts-v1/;
++
++#include "armada-3720-espressobin.dtsi"
++
++/ {
++ model = "Globalscale Marvell ESPRESSOBin Board (eMMC)";
++ compatible = "globalscale,espressobin-emmc", "globalscale,espressobin",
++ "marvell,armada3720", "marvell,armada3710";
++};
++
++/* U11 */
++&sdhci1 {
++ non-removable;
++ bus-width = <8>;
++ mmc-ddr-1_8v;
++ mmc-hs400-1_8v;
++ marvell,xenon-emmc;
++ marvell,xenon-tun-count = <9>;
++ marvell,pad-type = "fixed-1-8v";
++
++ pinctrl-names = "default";
++ pinctrl-0 = <&mmc_pins>;
++ status = "okay";
++
++ #address-cells = <1>;
++ #size-cells = <0>;
++ mmccard: mmccard@0 {
++ compatible = "mmc-card";
++ reg = <0>;
++ };
++};
+--- a/doc/README.marvell
++++ b/doc/README.marvell
+@@ -43,8 +43,11 @@ Build Procedure
+ In order to prevent this, the required device-tree MUST be set during compilation.
+ All device-tree files are located in ./arch/arm/dts/ folder.
+
+- For other DB boards (MacchiatoBin, EspressoBin and 3700 DB board) compile u-boot with
+- just default device-tree from defconfig using:
++ For the EspressoBin board with populated eMMC device use
++ # make DEVICE_TREE=armada-3720-espressobin-emmc
++
++ For other DB boards (MacchiatoBin, EspressoBin without soldered eMMC and 3700 DB board)
++ compile u-boot with just default device-tree from defconfig using:
+
+ # make
+