aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index a8256529bf..f6745f6cad 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -27,7 +27,14 @@ define U-Boot/mt7622
UBOOT_CONFIG:=mt7622_rfb
endef
-UBOOT_TARGETS := mt7629 mt7622
+define U-Boot/mt7623n_bpir2
+ NAME:=Banana Pi R2 (mt7623)
+ BUILD_SUBTARGET:=mt7623
+ UBOOT_IMAGE:=u-boot.bin
+ UBOOT_CONFIG:=mt7623n_bpir2
+endef
+
+UBOOT_TARGETS := mt7629 mt7622 mt7623n_bpir2
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)