aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index c71ed67f58..269c9e5db5 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -54,6 +54,17 @@ define U-Boot/mt7622_bananapi_bpi-r64-sdmmc
DEPENDS:=+trusted-firmware-a-mt7622-sdmmc-2ddr
endef
+define U-Boot/mt7622_ubnt_unifi-6-lr
+ NAME:=Ubiquiti UniFi 6 LR
+ UBOOT_CONFIG:=mt7622_ubnt_unifi-6-lr
+ BUILD_DEVICES:=ubnt_unifi-6-lr-ubootmod
+ BUILD_SUBTARGET:=mt7622
+ UBOOT_IMAGE:=u-boot.fip
+ BL2_BOOTDEV:=nor
+ BL2_DDRBLOB:=2
+ DEPENDS:=+trusted-firmware-a-mt7622-nor-2ddr
+endef
+
define U-Boot/mt7623a_unielec_u7623
NAME:=UniElec U7623 (mt7623)
BUILD_DEVICES:=unielec_u7623-emmc unielec_u7623-02-emmc-512m-legacy
@@ -81,6 +92,7 @@ UBOOT_TARGETS := \
mt7622_bananapi_bpi-r64-sdmmc \
mt7622_linksys_e8450 \
mt7622_rfb1 \
+ mt7622_ubnt_unifi-6-lr \
mt7623n_bpir2 \
mt7623a_unielec_u7623 \
mt7629_rfb