aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index a7b47ecae5..8cb20075a3 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -15,18 +15,18 @@ define U-Boot/Default
DEFAULT:=y
endef
-define U-Boot/mt7629
- NAME:=MT7629
- BUILD_SUBTARGET:=mt7629
- UBOOT_CONFIG:=mt7629_rfb
-endef
-
define U-Boot/mt7622
NAME:=MT7622
BUILD_SUBTARGET:=mt7622
UBOOT_CONFIG:=mt7622_rfb
endef
+define U-Boot/mt7623a_unielec_u7623
+ NAME:=UniElec U7623 (mt7623)
+ BUILD_SUBTARGET:=mt7623
+ UBOOT_CONFIG:=mt7623a_unielec_u7623_02
+endef
+
define U-Boot/mt7623n_bpir2
NAME:=Banana Pi R2 (mt7623)
BUILD_SUBTARGET:=mt7623
@@ -34,7 +34,13 @@ define U-Boot/mt7623n_bpir2
UBOOT_CONFIG:=mt7623n_bpir2
endef
-UBOOT_TARGETS := mt7629 mt7622 mt7623n_bpir2
+define U-Boot/mt7629
+ NAME:=MT7629
+ BUILD_SUBTARGET:=mt7629
+ UBOOT_CONFIG:=mt7629_rfb
+endef
+
+UBOOT_TARGETS := mt7629 mt7622 mt7623n_bpir2 mt7623a_unielec_u7623
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)