aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape-armv8_32b/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-layerscape-armv8_32b/Makefile')
-rw-r--r--package/boot/uboot-layerscape-armv8_32b/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/package/boot/uboot-layerscape-armv8_32b/Makefile b/package/boot/uboot-layerscape-armv8_32b/Makefile
index 85e338ade4..d204a30ec4 100644
--- a/package/boot/uboot-layerscape-armv8_32b/Makefile
+++ b/package/boot/uboot-layerscape-armv8_32b/Makefile
@@ -8,18 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-layerscape-armv8_32b
-PKG_VERSION:=v1.0
+PKG_VERSION:=2017.09
PKG_RELEASE:=1
+# Layerscape ARMv8 platforms use 64-bit u-boot to support both 32-bit and 64-bit
+# kernel/rootfs. Since LEDE could only provide 32-bit toolchain for 32-bit targets,
+# 64-bit u-boot images git tree is provided here whose source code actually is
+# uboot-layerscape's source code.
PKG_SOURCE_PROTO:=git
-PKG_MIRROR_HASH:=a29edbeddde4b3007ac349c2a5ee434719049ac4753e459dbb1bab21e1c585da
-PKG_SOURCE_URL:=https://github.com/fsl-jyt/uboot-ls-32b.git
-PKG_SOURCE_VERSION:=6476195551ea83193afd06d0c441483c04729c8d
+PKG_SOURCE_URL:=https://github.com/yangbolu1991/u-boot-lede.git
+PKG_SOURCE_VERSION:=6c811b70dc7b9f34ad666d48d071c4dbc4b8365a
+PKG_MIRROR_HASH:=db5e277885cae722fcd31e58fd1a6a04456fbe1fe2d50869a1ae4bca44b74989
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
-
-PKG_MAINTAINER:=Jiang Yutang <jiangyutang1978@gmail.com>
+PKG_MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/kernel.mk
@@ -45,7 +46,7 @@ define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/ls1043ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1043ardb-armv8_32b-uboot.bin
$(CP) $(PKG_BUILD_DIR)/ls1046ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1046ardb-armv8_32b-uboot.bin
- $(CP) $(PKG_BUILD_DIR)/ls1012ardb-uboot.bin.swap $(STAGING_DIR_IMAGE)/ls1012ardb-armv8_32b-uboot.bin
+ $(CP) $(PKG_BUILD_DIR)/ls1012ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1012ardb-armv8_32b-uboot.bin
endef
$(eval $(call BuildPackage,uboot-layerscape-armv8_32b))