aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape-armv8_32b/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-layerscape-armv8_32b/Makefile')
-rw-r--r--package/boot/uboot-layerscape-armv8_32b/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/package/boot/uboot-layerscape-armv8_32b/Makefile b/package/boot/uboot-layerscape-armv8_32b/Makefile
new file mode 100644
index 0000000000..85e338ade4
--- /dev/null
+++ b/package/boot/uboot-layerscape-armv8_32b/Makefile
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2016 Jiang Yutang <jiangyutang1978@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=uboot-layerscape-armv8_32b
+PKG_VERSION:=v1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_MIRROR_HASH:=a29edbeddde4b3007ac349c2a5ee434719049ac4753e459dbb1bab21e1c585da
+PKG_SOURCE_URL:=https://github.com/fsl-jyt/uboot-ls-32b.git
+PKG_SOURCE_VERSION:=6476195551ea83193afd06d0c441483c04729c8d
+
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
+PKG_MAINTAINER:=Jiang Yutang <jiangyutang1978@gmail.com>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+define Package/uboot-layerscape-armv8_32b
+ SECTION:=boot
+ CATEGORY:=Boot Loaders
+ DEPENDS:=@TARGET_layerscape_armv8_32b
+ TITLE:=U-Boot for ARMv8 32-bit based Layerscape boards
+ DEFAULT:=y
+ HIDDEN:=1
+endef
+
+define Build/Configure
+
+endef
+
+define Build/Compile
+
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(CP) $(PKG_BUILD_DIR)/ls1043ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1043ardb-armv8_32b-uboot.bin
+ $(CP) $(PKG_BUILD_DIR)/ls1046ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1046ardb-armv8_32b-uboot.bin
+ $(CP) $(PKG_BUILD_DIR)/ls1012ardb-uboot.bin.swap $(STAGING_DIR_IMAGE)/ls1012ardb-armv8_32b-uboot.bin
+endef
+
+$(eval $(call BuildPackage,uboot-layerscape-armv8_32b))