aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-imx/Makefile')
-rw-r--r--package/boot/uboot-imx/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/package/boot/uboot-imx/Makefile b/package/boot/uboot-imx/Makefile
new file mode 100644
index 0000000000..9ca4d55a1c
--- /dev/null
+++ b/package/boot/uboot-imx/Makefile
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2013-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_VERSION:=2020.04
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
+
+include $(INCLUDE_DIR)/u-boot.mk
+include $(INCLUDE_DIR)/package.mk
+
+define U-Boot/Default
+ BUILD_TARGET:=imx
+ UBOOT_IMAGE:=u-boot.imx
+endef
+
+define U-Boot/apalis_imx6
+ NAME:=Toradex Apalis
+ UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
+ UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+ BUILD_DEVICES:=toradex_apalis
+endef
+
+define U-Boot/mx6cuboxi
+ NAME:=SolidRun Cubox-i boards
+ UBOOT_IMAGE:=SPL u-boot.img
+ UBOOT_MAKE_FLAGS:=SPL u-boot.img
+ BUILD_DEVICES:=solidrun_cubox-i
+endef
+
+define U-Boot/wandboard
+ NAME:=Wandboard Dual Lite/Quad/Solo
+ BUILD_DEVICES:=wandboard_dual
+endef
+
+UBOOT_TARGETS := \
+ apalis_imx6 \
+ mx6cuboxi \
+ wandboard
+
+UBOOT_MAKE_FLAGS += u-boot.imx
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(foreach img,$(UBOOT_IMAGE), \
+ $(CP) $(PKG_BUILD_DIR)/$(img) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(img); \
+ )
+endef
+
+$(eval $(call BuildPackage/U-Boot))