aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/patches/001-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-envtools/patches/001-compile.patch')
-rw-r--r--package/boot/uboot-envtools/patches/001-compile.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/boot/uboot-envtools/patches/001-compile.patch b/package/boot/uboot-envtools/patches/001-compile.patch
index f7ec9130d6..34072f309d 100644
--- a/package/boot/uboot-envtools/patches/001-compile.patch
+++ b/package/boot/uboot-envtools/patches/001-compile.patch
@@ -1,6 +1,6 @@
--- a/tools/env/Makefile
+++ b/tools/env/Makefile
-@@ -10,6 +10,10 @@
+@@ -8,6 +8,10 @@
# with "CC" here for the maximum code reuse of scripts/Makefile.host.
override HOSTCC = $(CC)
@@ -9,5 +9,5 @@
+endif
+
# Compile for a hosted environment on the target
- HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
- -idirafter $(srctree)/tools/env \
+ HOST_EXTRACFLAGS = -I$(srctree)/tools \
+ $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \