aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-at91/Makefile')
-rw-r--r--package/boot/uboot-at91/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 2c95377b0f..e2d3ed0322 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -42,11 +42,26 @@ define uboot/sama5d3_xplained_mmc
BUILD_DEVICES:=at91-sama5d3_xplained
endef
+define uboot/sama5d2_xplained_spiflash
+ TITLE:=U-Boot for the SAMA5D2 Xplained board (SPI Flash)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=at91-sama5d2_xplained
+endef
+
+define uboot/sama5d2_xplained_mmc
+ TITLE:=U-Boot for the SAMA5D2 Xplained board (SDcard/EMMC)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=at91-sama5d2_xplained
+endef
+
UBOOT_TARGETS := \
at91sam9m10g45ek_nandflash \
at91sam9x5ek_nandflash \
sama5d3_xplained_nandflash \
- sama5d3_xplained_mmc
+ sama5d3_xplained_mmc \
+ sama5d2_xplained_mmc \
+ sama5d2_xplained_spiflash
+
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \