aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-at91/Makefile')
-rw-r--r--package/boot/uboot-at91/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index fd58b9009e..f0a4ba56c2 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/kernel.mk
define U-Boot/Default
BUILD_TARGET:=at91
HIDDEN:=1
- UBOOT_IMAGE:=u-boot.bin boot.bin
+ UBOOT_IMAGE:=u-boot.bin
endef
define U-Boot/at91sam9m10g45ek_nandflash
@@ -92,6 +92,18 @@ define U-Boot/sama5d27_som1_ek_spiflash
BUILD_DEVICES:=at91-sama5d27_som1_ek
endef
+define U-Boot/sama5d2_ptc_ek_nandflash
+ NAME:=SAMA5D2 PTC Ek (Nand Flash)
+ BUILD_SUBTARGET:=sama5d2
+ BUILD_DEVICES:=at91-sama5d2_ptc_ek
+endef
+
+define U-Boot/sama5d2_ptc_ek_mmc
+ NAME:=SAMA5D2 PTC Ek (SDCard)
+ BUILD_SUBTARGET:=sama5d2
+ BUILD_DEVICES:=at91-sama5d2_ptc_ek
+endef
+
UBOOT_TARGETS := \
at91sam9m10g45ek_nandflash \
at91sam9x5ek_nandflash \
@@ -103,7 +115,9 @@ UBOOT_TARGETS := \
sama5d4_xplained_spiflash \
sama5d4_xplained_nandflash\
sama5d27_som1_ek_mmc \
- sama5d27_som1_ek_spiflash
+ sama5d27_som1_ek_spiflash \
+ sama5d2_ptc_ek_nandflash \
+ sama5d2_ptc_ek_mmc
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \