aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-at91/Makefile')
-rw-r--r--package/boot/uboot-at91/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 7c420f1262..268b254206 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -88,7 +88,7 @@ UBOOT_TARGETS := \
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE=$(TARGET_CROSS) \
- KCFLAGS="$(filter-out -fstack-protector, $(TARGET_CFLAGS))"
+ KCFLAGS="$(filter-out -fstack-protector -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
endef
$(eval $(call BuildPackage/U-Boot))