aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/tfa-layerscape
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/tfa-layerscape')
-rw-r--r--package/boot/tfa-layerscape/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/package/boot/tfa-layerscape/Makefile b/package/boot/tfa-layerscape/Makefile
index c0efd3ad9e..d5a1664278 100644
--- a/package/boot/tfa-layerscape/Makefile
+++ b/package/boot/tfa-layerscape/Makefile
@@ -123,6 +123,20 @@ define Package/tfa-ls2088a-rdb
BOOT_MODE:=nor
endef
+define Package/tfa-lx2160a-rdb
+ $(Package/tfa-generic)
+ TITLE:=NXP LX2160ARDB Trusted Firmware
+ PLAT:=lx2160ardb
+ BOOT_MODE:=flexspi_nor
+endef
+
+define Package/tfa-lx2160a-rdb-sdboot
+ $(Package/tfa-generic)
+ TITLE:=NXP LX2160ARDB SD Boot Trusted Firmware
+ PLAT:=lx2160ardb
+ BOOT_MODE:=sd
+endef
+
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/build/$(PLAT)/release/bl2_$(BOOT_MODE).pbl \
@@ -154,7 +168,9 @@ TFAS := \
ls1046a-rdb-sdboot \
ls1088a-rdb \
ls1088a-rdb-sdboot \
- ls2088a-rdb
+ ls2088a-rdb \
+ lx2160a-rdb \
+ lx2160a-rdb-sdboot
$(eval $(call HostBuild))
$(foreach tfa,$(TFAS), \