aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/tfa-layerscape/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/tfa-layerscape/Makefile')
-rw-r--r--package/boot/tfa-layerscape/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/boot/tfa-layerscape/Makefile b/package/boot/tfa-layerscape/Makefile
index 072036da2f..adcc005b83 100644
--- a/package/boot/tfa-layerscape/Makefile
+++ b/package/boot/tfa-layerscape/Makefile
@@ -63,6 +63,18 @@ define Trusted-Firmware-A/ls1012a-frwy-sdboot
BOOT_MODE:=qspi
endef
+define Trusted-Firmware-A/ls1028a-rdb
+ TITLE:=NXP LS1028ARDB
+ PLAT:=ls1028ardb
+ BOOT_MODE:=flexspi_nor
+endef
+
+define Trusted-Firmware-A/ls1028a-rdb-sdboot
+ TITLE:=NXP LS1028ARDB SD Boot
+ PLAT:=ls1028ardb
+ BOOT_MODE:=sd
+endef
+
define Trusted-Firmware-A/ls1043a-rdb
NAME:=NXP LS1043ARDB
PLAT:=ls1043ardb
@@ -133,6 +145,8 @@ TFA_TARGETS := \
ls1012a-frdm \
ls1012a-rdb \
ls1012a-frwy-sdboot \
+ ls1028a-rdb \
+ ls1028a-rdb-sdboot \
ls1043a-rdb \
ls1043a-rdb-sdboot \
ls1046a-frwy \