aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/rbcfg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/rbcfg/Makefile')
-rw-r--r--package/boot/rbcfg/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/package/boot/rbcfg/Makefile b/package/boot/rbcfg/Makefile
deleted file mode 100644
index 874ef06924..0000000000
--- a/package/boot/rbcfg/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=rbcfg
-PKG_RELEASE:=3
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-PKG_FLAGS:=nonshared
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/rbcfg
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=Boot Loaders
- TITLE:=RouterBOOT configuration tool
- DEPENDS:=@(TARGET_ar71xx||TARGET_ath79)
-endef
-
-define Package/rbcfg/description
- This package contains an utility to manipulate RouterBOOT configuration on the
- MikroTIK RB-4XX devices.
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC="$(TARGET_CC)" \
- CFLAGS="$(TARGET_CFLAGS) -Wall" \
- LDFLAGS="$(TARGET_LDFLAGS)"
-endef
-
-define Package/rbcfg/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/rbcfg $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,rbcfg))