aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/at91bootstrap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/at91bootstrap/Makefile')
-rw-r--r--package/boot/at91bootstrap/Makefile24
1 files changed, 21 insertions, 3 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 2d77f70997..92dbf27a1e 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -9,13 +9,31 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=at91bootstrap
-PKG_VERSION:=v3.9.3
+PKG_VERSION:=v4.0.1
+PKG_MIRROR_HASH:=3d45a4bcb52162097d4cdf042b8fe1ccf53e88b512e7541f42a23f2a73692a69
+PKG_SOURCE_VERSION:=4d41296e9ae12379555fb46a941897e7264600a2
+BINARIES_DIR:=build/binaries
+
+AT91BOOTSTRAP_V4=y
+ifdef CONFIG_PACKAGE_at91bootstrap-sama5d4_xplaineddf_uboot_secure
+ AT91BOOTSTRAP_V4=n
+else ifdef CONFIG_TARGET_at91_sam9x
+ ifndef CONFIG_TARGET_at91_sam9x_DEVICE_microchip_sam9x60ek
+ AT91BOOTSTRAP_V4=n
+ endif
+endif
+
+ifeq ($(AT91BOOTSTRAP_V4),n)
+ PKG_VERSION=v3.10.4
+ PKG_MIRROR_HASH=6fe61fe90838e785917383bb9e887fa05e1bd061a6725954242f504e38b5c426
+ PKG_SOURCE_VERSION=404846dd283894367a015ca59189bcf927d92e11
+ BINARIES_DIR=binaries
+endif
+
PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/linux4sam/at91bootstrap.git
-PKG_MIRROR_HASH:=06753d673756edc9753932db00f4e5b8c1f9fa7708337c4d6ce280573efb86b4
-PKG_SOURCE_VERSION:=d96833a4b6680b237708eb4dc9f10708b9e709d8
PKG_BUILD_DIR = \
$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)