aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/arm-trusted-firmware-mvebu/patches/200-hostssl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/arm-trusted-firmware-mvebu/patches/200-hostssl.patch')
-rw-r--r--package/boot/arm-trusted-firmware-mvebu/patches/200-hostssl.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/boot/arm-trusted-firmware-mvebu/patches/200-hostssl.patch b/package/boot/arm-trusted-firmware-mvebu/patches/200-hostssl.patch
new file mode 100644
index 0000000000..fc1a24a8ff
--- /dev/null
+++ b/package/boot/arm-trusted-firmware-mvebu/patches/200-hostssl.patch
@@ -0,0 +1,20 @@
+--- a/tools/fiptool/Makefile
++++ b/tools/fiptool/Makefile
+@@ -19,7 +19,7 @@ ifeq (${DEBUG},1)
+ else
+ HOSTCCFLAGS += -O2
+ endif
+-LDLIBS := -lcrypto
++LDLIBS := -L${OPENSSL_DIR}/lib -lcrypto
+
+ ifeq (${V},0)
+ Q := @
+@@ -27,7 +27,7 @@ else
+ Q :=
+ endif
+
+-INCLUDE_PATHS := -I../../include/tools_share
++INCLUDE_PATHS := -I../../include/tools_share -I${OPENSSL_DIR}/include
+
+ HOSTCC ?= gcc
+