aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 78c3dc9390..512fa66ca7 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -168,6 +168,10 @@ define Package/base-files/install
echo "$$$${conffile##$(1)}" >> $(1)/CONTROL/conffiles; \
fi \
done
+
+ $(if $(CONFIG_INCLUDE_CONFIG), \
+ echo -e "# Build configuration for board $(BOARD)/$(SUBTARGET)/$(PROFILE)\n" >$(1)/etc/build.config; \
+ cat $(BIN_DIR)/config.seed >>$(1)/etc/build.config)
endef
ifneq ($(DUMP),1)