aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 5f816a0d1b..f19b07cfe1 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -23,6 +23,7 @@ PKG_LICENSE:=GPL-2.0
PKG_CONFIG_DEPENDS += \
CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE \
CONFIG_NAND_SUPPORT \
+ CONFIG_SDCARD_SUPPORT \
CONFIG_CLEAN_IPKG \
CONFIG_PER_FEED_REPO \
$(foreach feed,$(FEEDS_AVAILABLE),CONFIG_FEED_$(feed))
@@ -123,10 +124,18 @@ ifeq ($(CONFIG_NAND_SUPPORT),)
endef
endif
+ifeq ($(CONFIG_SDCARD_SUPPORT),)
+ define Package/base-files/sdcard-support
+ rm -f $(1)/lib/upgrade/sdcard.sh
+ endef
+endif
+
+
define Package/base-files/install
$(CP) ./files/* $(1)/
$(Package/base-files/install-key)
$(Package/base-files/nand-support)
+ $(Package/base-files/sdcard-support)
if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
fi