aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index cc6ce5d2a1..eadfb9b151 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -80,6 +80,13 @@ define Package/libssp
TITLE:=GCC support library
endef
+define Package/libstdcpp
+ $(call Package/gcc/Default)
+ NAME:=libstdc++
+ TITLE:=GNU Standard C++ Library v3
+ DEPENDS:=@!NATIVE_TOOLCHAIN&&@INSTALL_LIBSTDCPP
+endef
+
define Package/uclibc/Default
SECTION:=libs
CATEGORY:=Base system
@@ -161,6 +168,11 @@ ifeq ($(word 1,$(subst ., ,$(LIBGCC_VERSION))),4)
endef
endif
+define Package/libstdcpp/install
+ $(INSTALL_DIR) $(1)/lib
+ $(CP) $(STAGING_DIR)/lib/libstdc++.so.* $(1)/lib/
+endef
+
define Package/libpthread/install
$(INSTALL_DIR) $(1)/lib
$(CP) $(STAGING_DIR)/lib/libpthread.so.* $(1)/lib/
@@ -192,5 +204,6 @@ endif
$(eval $(call BuildPackage,base-files$(TARGET)))
$(eval $(call BuildPackage,libgcc))
$(eval $(call BuildPackage,libssp))
+$(eval $(call BuildPackage,libstdcpp))
$(eval $(call BuildPackage,libpthread))
$(eval $(call BuildPackage,uclibc))