aboutsummaryrefslogtreecommitdiffstats
path: root/package/acx-mac80211/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/acx-mac80211/patches')
-rw-r--r--package/acx-mac80211/patches/003-build_as_modules.patch13
-rw-r--r--package/acx-mac80211/patches/004-ratelimit_compile_fix.patch10
2 files changed, 4 insertions, 19 deletions
diff --git a/package/acx-mac80211/patches/003-build_as_modules.patch b/package/acx-mac80211/patches/003-build_as_modules.patch
deleted file mode 100644
index e0a3fd0e72..0000000000
--- a/package/acx-mac80211/patches/003-build_as_modules.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: acx-mac80211-20120422/Makefile
-===================================================================
---- acx-mac80211-20120422.orig/Makefile 2012-04-23 17:35:13.000000000 +0200
-+++ acx-mac80211-20120422/Makefile 2012-04-23 17:36:55.386257951 +0200
-@@ -30,7 +30,7 @@
- acx-mac80211-obj-$(CONFIG_ACX_MAC80211_PCI) += pci.o
- acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
- acx-mac80211-obj-$(CONFIG_ACX_MAC80211_MEM) += mem.o
-- acx-mac80211-objs := common.o $(acx-mac80211-obj-y) merge.o
-+ acx-mac80211-objs := common.o $(acx-mac80211-obj-m) merge.o
-
- else
- # Otherwise we were called directly from the command line: the kernel build
diff --git a/package/acx-mac80211/patches/004-ratelimit_compile_fix.patch b/package/acx-mac80211/patches/004-ratelimit_compile_fix.patch
index a30e3dc7dc..56110eab0c 100644
--- a/package/acx-mac80211/patches/004-ratelimit_compile_fix.patch
+++ b/package/acx-mac80211/patches/004-ratelimit_compile_fix.patch
@@ -1,9 +1,7 @@
-Index: acx-mac80211-20120422/common.c
-===================================================================
---- acx-mac80211-20120422.orig/common.c 2012-04-23 17:35:13.000000000 +0200
-+++ acx-mac80211-20120422/common.c 2012-04-23 17:37:02.818257747 +0200
-@@ -33,6 +33,7 @@
- #include <linux/ethtool.h>
+--- a/common.c
++++ b/common.c
+@@ -34,6 +34,7 @@
+ #include <linux/pci.h>
#include <linux/nl80211.h>
#include <linux/ieee80211.h>
+#include <linux/ratelimit.h>