aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile28
1 files changed, 0 insertions, 28 deletions
diff --git a/package/Makefile b/package/Makefile
index 17378a95ef..3250e7b7d0 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -74,15 +74,6 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install $(curdir
$(call prepare_rootfs,$(TARGET_DIR))
-PASSOPT=""
-PASSARG=""
-ifndef CONFIG_OPKGSMIME_PASSPHRASE
- ifneq ($(call qstrip,$(CONFIG_OPKGSMIME_PASSFILE)),)
- PASSOPT="-passin"
- PASSARG="file:$(call qstrip,$(CONFIG_OPKGSMIME_PASSFILE))"
- endif
-endif
-
$(curdir)/index: FORCE
@echo Generating package index...
@for d in $(PACKAGE_SUBDIRS); do ( \
@@ -99,25 +90,6 @@ ifdef CONFIG_SIGNED_PACKAGES
cd $$d || continue; \
$(STAGING_DIR_HOST)/bin/usign -S -m Packages -s $(BUILD_KEY); \
); done
-else
-ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_KEY)),)
- @echo Signing key has not been configured
-else
-ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_CERT)),)
- @echo Certificate has not been configured
-else
- @echo Signing package index...
- @for d in $(PACKAGE_SUBDIRS); do ( \
- [ -d $$d ] && \
- cd $$d || continue; \
- openssl smime -binary -in Packages.gz \
- -out Packages.sig -outform PEM -sign \
- -signer $(CONFIG_OPKGSMIME_CERT) \
- -inkey $(CONFIG_OPKGSMIME_KEY) \
- $(PASSOPT) $(PASSARG); \
- ); done
-endif
-endif
endif
$(curdir)/preconfig: