aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/Makefile b/package/Makefile
index 94241dbc3d..d6af3f28f7 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -34,6 +34,9 @@ endif
%-refresh %-update:
-$(MAKE) -C $* $(patsubst $*-%,%,$@)
+
+%-autorefresh:
+ -$(MAKE) -C $* clean refresh QUILT=1
# .IGNORE: $(COMPILE_PACKAGES)
@@ -46,9 +49,7 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
prereq: $(PREREQ_PACKAGES)
download: $(DOWNLOAD_PACKAGES)
compile: $(COMPILE_PACKAGES)
-ifneq ($(QUILT),)
- refresh: $(patsubst %,%-refresh,$(package-y) $(package-m) $(package-))
-endif
+refresh: $(patsubst %,%-autorefresh,$(package-y) $(package-m) $(package-))
install-targets: $(INSTALL_PACKAGES)
install: